Error while trying to test the webPart

Jun 16, 2011 at 8:07 AM
Edited Jun 16, 2011 at 11:11 AM

hi

am getting this error while trying to test the webPart, it appears when i pressed "select scanner" button

Creating an instance of the COM component with CLSID {E1C5D730-7E97-4D8A-9E42-BBAE87C2059F} from the IClassFactory failed due to the following error: 80070005.

 

any help ??!!!

Jun 17, 2011 at 11:21 PM

hi,

 Your error is a typical error message, if  IIS is not allowed to create instances of a  specific com component.

In order to make the webpart work, please perform the following steps:

1. Add access rights for the users IIS_IUSRS and NETWORKSERVICE to some DCOM-Components, which are:

-WIA Device Manager
-WIA Extension Host for 64 bit extensions

If you are not able to set any access permissions for this DCOM-Components - you have to take ownership to them via the registry, if you don't know how to do this, watch
this video: http://www.youtube.com/watch?v=F2tcSHh4bGQ

 

Jun 18, 2011 at 3:56 PM

Hi,

i already did what is mentioned in your post, but still not working !!!! :(

Jun 21, 2011 at 9:08 AM

Hi,

please check out this link on the MSDN-Forums, you have a problem accessing wiaaut.dll. Please follow the steps mentioned there.

http://social.msdn.microsoft.com/Forums/pl-PL/netfxbcl/thread/a75e45e3-5bed-4ba7-ba70-80656e41a2ee

Thank you.

 

Jul 18, 2011 at 8:13 AM

It technically worked & thanks for that, but my scanned images are incomplete, there is only half of my document scanned.

How can I fix this.

thnx in advance pals!

Aug 24, 2011 at 12:13 PM

Hi, sorry for the late reply, but this is problem occurs, because the paper size is fix. It is set hardcoded to A4. I will implement to choose the paper size you use in your countries.

In the next few days I will also publish a concept, for the next generation of this software. It will be turned into donation-ware. You can donate what you want - even nothing - it will

not influence the functionality of the software. I will also need your and the suggestions of other users regarding the concept.

thx.